Browser Compatibility

Overview

We support the current and one previous major versions of Chrome, Firefox, Safari, and Edge. Soon after a new version is released, we begin supporting it and stop formally supporting the third oldest version (though in many cases it will still work -- it will simply no longer be aggressively tested). 

We also support Internet Explorer, version 11 only. This is in line with Microsoft, who has dropped support for earlier versions.  

Libris is designed to take advantage of features found in the most recent versions of popular web browsers. This commitment helps to ensure that our platform and the services we provide remain fast, reliable, and secure. 

In general, we recommend the latest stable version of Google Chrome or Mozilla Firefox. Libris may not work as expected when used with an unsupported or old browser. Organizations that depend on old versions of Internet Explorer may want to consider a dual browser strategy, especially for video playback in the Library or Portal.

Browser Settings

All browsers must have cookies and JavaScript enabled to use Libris. Programs that block JavaScript should be avoided. This includes browser plug-ins or other programs that interfere with normal browser functions.

To view videos in a Library or Portal, browsers must also have Flash enabled.

Libris does not officially support browsers set to incognito mode/private browsing.

Still have questions? Contact us.

Comments

Back to Libris
Powered by Zendesk